【程序员Bug集锦】Unable to look up github.com (port 9418)

在执行

1
$ npm install

安装node相关依赖的时候,出现一些诡异的错误

错误截图

1
2
3
4
5
6
7
8
9
npm WARN deprecated left-pad@1.3.0: use String.prototype.padStart()
npm ERR! Error while executing:
npm ERR! D:\Git\mingw64\bin\git.EXE ls-remote -h -t git://github.com/adobe-webplatform/eve.git
npm ERR!
npm ERR! fatal: unable to look up github.com (port 9418) (Ӧ�ó���û�е��� WSAStartup������ WSAStartup ʧ�ܡ� )
npm ERR!
npm ERR! exited with error code: 128

npm ERR! A complete log of this run can be found in:

原因是通过 git:// 方式连接github的时候,失败!!

因此修改连接方式:

1
git config --global url."https://".insteadOf git://

修改git config即可 git config –global url.”https://“.insteadOf git://

继续 npm install 安装

OK, 成功

坚持原创技术分享,谢谢鼓励我继续创作!